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PAYROLL DATA INTEGRITY AND VALIDATION 

Maintaining the integrity of employee information between the Employee Maintenance and Employee 
Positions and Pay windows can be challenging when employees change jobs. The challenge can be 
heightened when two different departments are responsible for entering the data. 

In this class, you’ll learn how to quickly and easily identify discrepancies between Employee Maintenance 
and Positions & Pay, utilizing grid layouts and Excel.  

In this class, we will cover the following: 

1. How to create and save several grid layouts in the Employee Positions and Pay window 

 Verify Employee Information 

 Verify FTE to Leave Factor 

 Verify Pay Basis to Pay Method to Work Calendar 

 Verify Pay Information 

 Verify Timecard and Substitute Information 

 Verify Work Calendar Information 

2. How to use Excel to identify discrepancies in the data 

 Export the grid to Excel 

 Turn on the Filter options 
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There are many Filter Criteria options in the Employee Positions and Pay grid to choose from for data 
validation. The examples provided in this document may be adjusted for individual client needs. All grids 
may be accessed from Payroll > Employees > Employee Positions and Pay. 

Verify Employee Information 

The purpose of this grid layout is to compare the Primary Job Title from Employee Maintenance to the 
employee’s Position Type, Description, State Code Description, and Classification from Positions & Pay to 
locate any discrepancies that need to be corrected.  

1. In the Filter Criteria, choose Position for Pay Type and Filled for Vacancy Status and select Apply 
Selection to get every position on the grid.  

NOTE  You can also filter the grid by the Open or Closed Status depending on the focus of your 
data validation. 

BEST PRACTICE  Populate the grid with data before creating grid layouts. 

 

2. Once the data is in the grid, arrange the columns in the following order, from left to right: 

1. Employee ID 

2. Name 

3. DAC 

4. Department 

5. Primary Job Title 

6. Position Type 

7. Description 

8. State Code Description 

9. Classification 

3. Highlight the nine columns and use your right mouse menu to select Show Columns. This limits 
the grid to nine columns of data. 

4. Set your cursor in one of the Primary Job Title fields. Right-click the mouse and select A to Z Sort 
Ascending from the menu.  



 

 
3 

 

5. You grid layout is now ready to save. Right-click and select Save Layout.  

6. Name the grid and mark the Save Grid Filter and Sort checkbox. 

7. Select Public as the Visibility option.  

These settings ensure the next time you load this layout, the grid shows only the nine columns desired, 
sorted in ascending order by Primary Job Title. This grid layout is also accessible to other users who have 
access to this window.  

 

Now that the grid layout is saved, you can right-click and select Load Layout to load this grid layout or 
other saved layouts in the future. 

8. Right-click and select Export to Excel from the menu.  
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9. On the Home tab in Excel, select Filter from the Sort & Filter dropdown. Every column now 
includes a dropdown option.  

10. Select View > Freeze Top Row. This Best Practice keeps the top row from scrolling out of sight as 
you work in the grid. 

 

At this point, you have a variety of options for validating the data. You can filter on the DAC column and 
verify the information from that view or you can filter by Primary Job Title and validate data from that 
view. This allows you to review the data easily and find discrepancies. 
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You can see below that by selecting the Business and Finance DAC, we were able to identify three 
possible discrepancies in the data. 

 

 

Verify FTE to Leave Factor 

The purpose of this grid layout is to compare the employee FTE to the Leave Factor from Positions & Pay 
and find any discrepancies that need to be corrected. Many districts align the Leave Factor to the FTE 
and, therefore, the two fields should be identical unless there are extenuating circumstances. 

1. In the Filter Criteria, choose Position for Pay Type and Filled for Vacancy Status and select Apply 
Selection to get every position on the grid.  

NOTE  You can also filter the grid by the Open or Closed Status depending on the focus of your 
data validation. 

BEST PRACTICE  Populate the grid with data before creating grid layouts. 

 

2. Once the data is in the grid, arrange the columns in the following order, from left to right: 
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1. Employee ID 

2. Name 

3. DAC 

4. Descripition 

5. Position Status 

6. FTE 

7. Leave Factor 

3. Highlight these seven columns. Right-click and select Show Columns to limit the grid to seven 
columns of data. 

4. Set your cursor in one of the Name fields. Right-click and select A to Z Sort Ascending.  

 

5. You grid layout is now ready to save. Right-click and select Save Layout.  

6. Name the grid and mark the Save Grid Filter and Sort checkbox. 

7. Select Public as the Visibility option.  

These settings ensure the next time you load this layout, the grid shows only the 7 columns desired and 
sorted in ascending order by Name. This grid layout is also accessible to other users who have access to 
this window.  



 

 
7 

  

Now that the grid layout is saved, you can right-click and select Load Layout to load this grid layout or 
other saved layouts in the future. 

8. Right-click and select Export to Excel from the menu.  

 

9. On the Home tab in Excel, select Filter from the Sort & Filter dropdown. Every column now 
includes a dropdown option.  

10. Select View > Freeze Top Row. This Best Practice keeps the top row from scrolling out of sight as 
you work in the grid. 

At this point we want to create a VARIANCE column that will calculate the difference between the FTE 
column and the Leave Factor column. This will quickly identify any employees who have a discrepancy. 
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Let’s find the discrepancies by selecting the dropdown option for the Variance column and deselecting 
the 0.000 option. 

 

 

The 7 records below should be reviewed and corrected if necessary. Don’t forget to look at their 
employee leave plans to see if there are accrual errors that also need to be corrected. 
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Verify Pay Basis to Pay Method to Work Calendar 

The purpose of this grid layout is to compare the employee Pay Basis (Hourly/Salary) to the Pay Method 
(Time Card/Work Agreement) against the Work Calendar in Positions & Pay. 

1. In the Filter Criteria, choose Position for Pay Type and Filled for Vacancy Status and select Apply 
Selection to get every position on the grid.  

NOTE  You can also filter the grid by the Open or Closed Status depending on the focus of your 
data validation. 

BEST PRACTICE  Populate the grid with data before creating grid layouts. 

 

2. Once the data is in the grid, arrange the columns in the following order, from left to right: 

1. Employee ID 

2. Name 

3. DAC 
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4. Descripition 

5. Pay Basis 

6. Pay Method 

7. Work Calendar 

3. Highlight the seven columns. Right-click and select Show Columns to limit the grid to seven 
columns of data. 

4. Set your cursor in one of the Pay Basis fields. Right-click and select A to Z Sort Ascending. 

 

5. You grid layout is now ready to save. Right-click and select Save Layout.  

6. Name the grid and mark the Save Grid Filter and Sort checkbox. 

7. Select Public as the Visibility option.  

These settings ensure the next time you load this layout, the grid shows only the seven columns desired 
and sorted in ascending order by Pay Basis. This grid layout is also accessible to other users who have 
access to this window.  
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Now that the grid layout is saved, you can right-click and select Load Layout to load this grid layout or 
other saved layouts in the future. 

8. Right-click and select Export to Excel from the menu.  

 

9. On the Home tab in Excel, select Filter from the Sort & Filter dropdown. Every column now 
includes a dropdown option.  

10. Select View > Freeze Top Row. This Best Practice keeps the top row from scrolling out of sight as 
you work in the grid. 

11. On the Pay Basis filter, select Hourly.  

12. On the Pay Method filter, select Time Card.  

13. Now, on the Work Calendar filter, select any Work Calendars that are not appropriate. 
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The four records below should be reviewed and corrected if necessary.  

 

 

Verify Pay Information 

The purpose of this grid layout is to review employee pay information for accuracy. 

1. In the Filter Criteria, choose Position for Pay Type and Filled for Vacancy Status and select Apply 
Selection to get every position on the grid.  
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NOTE  You can also filter the grid by the Open or Closed Status depending on the focus of your 
data validation. 

BEST PRACTICE  Populate the grid with data before creating grid layouts. 

 

2. Once the data is in the grid, arrange the columns in the following order, from left to right: 

1. Employee ID 

2. Name 

3. DAC 

4. Row Head 

5. Column Head 

6. Salary Schedule 

7. Description 

8. FTE 

9. Budget 

10. Amount 

11. Hours Per Day 

12. Rate 

13. Pay Basis 

14. Pay Method 

15. Start Date 

16. End Date 

17. Start Pay Period 

18. End Pay Period 

3. Highlight the 18 columns. Right-click and select Show Columns to limit the grid to 18 columns of 
data. 

4. Set your cursor in one of the Description fields. Right-click and select A to Z Sort Ascending. 
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5. You grid layout is now ready to save. Right-click and select Save Layout.  

6. Name the grid and mark the Save Grid Filter and Sort checkbox. 

7. Select Public as the Visibility option.  

These settings ensure the next time you load this layout, the grid shows only the 18 columns desired and 
sorted in ascending order by Primary Job Title. This grid layout is also accessible to other users who have 
access to this window.  

 

Now that the grid layout is saved, you can right-click and select Load Layout to load this grid layout or 
other saved layouts in the future. 

8. Right-click and select Export to Excel from the menu.  
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9. On the Home tab in Excel, select Filter from the Sort & Filter dropdown. Every column now 
includes a dropdown option.  

10. Select View > Freeze Top Row. This Best Practice keeps the top row from scrolling out of sight as 
you work in the grid. 

 

At this point, you have a variety of options for validating the data. You can filter on the Description 
column and verify the information from that view point or any other column. The idea is to provide a tool 
to review the data easily and find the discrepancies. 
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You can see below that by selecting the Hours Per Day colmn, we were able to identify nine possible 
discrepancies in the data. 

 

Verify Time Card and Substitute Information 

This grid layout is intended to be used by districts who have implemented a Time Card and/or Substitute 
interface.  

The purpose of this grid layout is to verify that employees who clock in and out of a timeclock system 
have been assigned the appropriate TCI Job, TCI Dept and TCI P fields. 

In addition, this grid layout can be used to verify employees who require a substitute have been assigned 
the appropriate SI Job Code. 

1. In the Filter Criteria, choose Position for Pay Type and Filled for Vacancy Status and select Apply 
Selection to get every position on the grid.  

NOTE  You can also filter the grid by the Open or Closed Status depending on the focus of your 
data validation. 

BEST PRACTICE  Populate the grid with data before creating grid layouts. 

 

2. Once the data is in the grid, arrange the columns in the following order, from left to right: 

1. Employee ID 
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2. Name 

3. DAC 

4. Descripition 

5. Classification 

6. TCI Job 

7. TCI Dept 

8. TCI P 

9. SI Job Code 

3. Highlight the nine columns. Right-click and select Show Columns to limit the grid to nine columns 
of data. 

4. Set your cursor in one of the Classification fields. Right-click and select A to Z Sort Ascending. 

 

5. You grid layout is now ready to save. Right-click and select Save Layout.  

6. Name the grid and mark the Save Grid Filter and Sort checkbox. 

7. Select Public as the Visibility option.  

These settings ensure the next time you load this layout, the grid shows only the 9 columns desired and 
sorted in ascending order by Pay Basis. This grid layout is also accessible to other users who have access 
to this window.  
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Now that the grid layout is saved, you can right-click and select Load Layout to load this grid layout or 
other saved layouts in the future. 

8. Right-click and select Export to Excel from the menu.  

 

9. On the Home tab in Excel, select Filter from the Sort & Filter dropdown. Every column now 
includes a dropdown option.  

10. Select View > Freeze Top Row. This Best Practice keeps the top row from scrolling out of sight as 
you work in the grid. 

11. On the Classification filter, select Classified. Using the TCI Job and TCI Dept filters, identify any 
missing or incorrect data. 
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12. Now, on the Classification filter, select Certified Non-Admin. 

13. Next, select the Description dropdown and type “Teacher” in the filter. 

14. Select Ok to show only teachers in the spreadsheet. Now you can identify any teachers who are 
missing the SI Job Code. (You can also filter on the Blanks on the SI Job Code filter.) 
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Verify Work Calendar Information 

The purpose of this grid layout is to review employee Work Calendar information including Start/End 
Dates, Start/End Pay Periods. 

1. In the Filter Criteria, choose Position for Pay Type and Filled for Vacancy Status and select Apply 
Selection to get every position on the grid.  

NOTE  You can also filter the grid by the Open or Closed Status depending on the focus of your 
data validation. 
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BEST PRACTICE  Populate the grid with data before creating grid layouts. 

 

2. Once the data is in the grid, arrange the columns in the following order, from left to right: 

1. Employee ID 

2. Name 

3. DAC 

4. Descripition 

5. Pay Basis 

6. Pay Method 

7. Work Calendar 

8. Start Date 

9. End Date 

10. Start Period 

11. End Period 

12. Position Days 

3. Highlight the 12 columns. Right-click and select Show Columns to limit the grid to 12 columns of 
data. 

4. Set your cursor in one of the Work Calendar fields. Right-click and select A to Z Sort Ascending.  
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5. You grid layout is now ready to save. Right-click and select Save Layout.  

6. Name the grid and mark the Save Grid Filter and Sort checkbox. 

7. Select Public as the Visibility option.  

These settings ensure the next time you load this layout, the grid shows only the 12 columns desired and 
sorted in ascending order by Name. This grid layout is also accessible to other users who have access to 
this window.  

 

Now that the grid layout is saved, you can right-click and select Load Layout to load this grid layout or 
other saved layouts in the future. 

8. Right-click and select Export to Excel from the menu.  
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9. On the Home tab in Excel, select Filter from the Sort & Filter dropdown. Every column now 
includes a dropdown option.  

10. Select View > Freeze Top Row. This Best Practice keeps the top row from scrolling out of sight as 
you work in the grid. 

The example below shows the 260 Day Actual Work Calendar has been selected and there are two 
employee records that don’t look right. A teacher is not normally on an Actual Work Calendar and a 
Custodian would not have a Start Period of 10 when their Start Date is 7/1/2018. 

 

As you can see, there are many Filter Criteria options in the Employee Positions and Pay grid that allow 
for data validation. 


